Technical Requirements

ZOOM

You will need the following to access your GLOMADO Workshop:

  • A computer or device with a webcam, speaker, and microphone
  • Zoom (video conferencing app)

To confirm Zoom is properly installed simply click here and follow the directions to Join a Test Meeting. This will check to see if you already have Zoom installed, and will prompt you to download and install it if you do not. It will also help you confirm that your webcam, speakers, and microphone are all working properly.

ZOOM for iOS: click here to download the app
ZOOM for Android: click here to download the app

System Requirements

  • An internet connection – broadband wired or wireless (3G or 4G/LTE)
  • Speakers and a microphone – built-in or USB plug-in or wireless Bluetooth
  • A webcam or HD webcam - built-in or USB plug-in
  • Or, a HD cam or HD camcorder with video capture card

Supported Operating Systems

  • Mac OS X with MacOS 10.7 or later
  • Windows 10
  • Windows 8 or 8.1
  • Windows 7
  • Windows Vista with SP1 or later
  • Windows XP with SP3 or later
  • Ubuntu 12.04 or higher
  • Mint 17.1 or higher
  • Red Hat Enterprise Linux 6.4 or higher
  • Oracle Linux 6.4 or higher
  • CentOS 6.4 or higher
  • Fedora 21 or higher
  • OpenSUSE 13.2 or higher
  • ArchLinux (64-bit only)

Supported Tablet and Mobile Devices

  • Surface PRO 2 running Win 8.1
  • Surface PRO 3 running Win 10
  • iOS and Android devices
  • Blackberry devices

Supported Browsers

  • Windows: Edge 12+, Firefox 27+,  Chrome 30+
  • Mac: Safari 7+, Firefox 27+,  Chrome 30+
  • Linux: Firefox 27+,  Chrome 30+